Home > DeveloperSection > Forums > IIS - this configuration section cannot be used at this path (configuration locking?)
Felix Pickles
Felix Pickles

Total Post:24

Posted on    July-17-2015 12:51 AM


 1 Reply(s)
 665  View(s)
Rate this:
I've encountered an error deploying a site to a server. When trying to load the home page, or access authentication on the new site in IIS, I get the error:

Config Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

More detail can be found Here, Scenario 7 matches my error hex.

The solution they give on the linked site above is to set "Allow" for overrideModeDefault in the section mentioned in my error, in the applicationHost.config file. In my case under security in system.webServer. But if I look at the applicationHost.config on my local computer, where the site is properly deployed already, that section is set to Deny.

So if this solution is correct, how is my local instance running just fine with the same web.config? According to my applicationHost.config, that section should be locked but it's not. I'd prefer to not have to change the applicationHost.config file, because there are many other sites running on that server. Is there another solution to this error?


Mayank Tripathi
Mayank Tripathi

Total Post:397

Posted on    July-17-2015 8:28 AM

I found it on the web, but here is what I did:

Click "Start button"
in the search box, enter "Turn windows features on or off"
in the features window, Click: "Internet Information Services"
Click: "World Wide Web Services"
Click: "Application Development Features"
Check (enable) the features. I checked all but CGI

Don't want to miss updates? Please click the below button!

Follow MindStick