Home > DeveloperSection > Forums > “Conversion to Dalvik format failed with error 1” on external JAR
ben reitman
ben reitman

Total Post:96

Points:676
Posted on    May-19-2015 1:35 AM

 Android Android 
Ratings:


 1 Reply(s)
 631  View(s)
Rate this:
In my Android application in Eclipse I get the following error.

UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Lorg/xmlpull/v1/XmlPullParser;
....
Conversion to Dalvik format failed with error 1
This error only appears when I add a specific external JAR file to my project. I searched for a long time for the possible solution, but none of the possible solutions work. I even tried to change to Android 1.6 instead of 1.5 (the current version I use).


Mayank Tripathi
Mayank Tripathi

Total Post:397

Points:3117
Posted on    May-19-2015 6:48 AM

I solved the problem.

It seems that I have two JAR files on my buildpath that include the same package and classes.

smack.jar and android_maps_lib-1.0.2

Deleting this package from one of the JAR files solved the problem.

Modified On May-19-2015 06:49:45 AM

Don't want to miss updates? Please click the below button!

Follow MindStick