HOW TO CONSUME WEBSERVICES FROM ASP.NET MVC APPLICATION

Takeshi Okada

Total Post:89

Points:629
Posted by  Takeshi Okada
 1014  View(s)
Ratings:
Rate this:

There is a external web services.

I can invoke it from my winform application, but I cannot invoke it from my asp.net mvc web application.

Error message is like this :

System.ServiceModel.EndpointNotFoundException: There was no endpoint listening at http://ihexds.nist.gov:9080/tf6/services/xdsrepositoryb that could accept the message. This is often caused by an incorrect address or SOAP action.

Is there anything to configure for my mvc web application to consume it?

Edit :

following is my code to invoke web services

WCF.Message msgInput, msgOutput;

msgInput = WCF.Message.CreateMessage(MESSAGE_VERSION, PROVIDEANDREGISTERDOCUMENTSETB_WSAACTION, request);

msgOutput = WCF.Message.CreateMessage(WCF.MessageVersion.Soap12WSAddressing10, "");

 

string endpointName = GetRepositoryEndPointName();

XDSRepository.XDSRepositoryClient client = new XDSRepository.XDSRepositoryClient(endpointName);

 

msgOutput = client.ProvideAndRegisterDocumentSet(msgInput);

  1. ezra heywood

    Post:145

    Points:1019
    Re: How to consume webservices from asp.net mvc application

    Judging from your comments, I think your problem is proxy server related. I think you're using a proxy server internal to your company. You have to specify in you web.config file that you want the dotnet code to use the credentials you're logged on with. Add this to your web.config and try again:

    <system.net>

        <defaultProxy enabled="true" useDefaultCredentials="true" >

        </defaultProxy>

    </system.net>

    It's also possible that you're working with a .pac script. In that case you have to explicitly specify the proxy server like so:

    <system.net>

        <defaultProxy useDefaultCredentials="true">

            <proxy proxyaddress="http://proxyserver:proxyport"/>

        </defaultProxy>

    </system.net>

Answer

NEWSLETTER

Enter your email address here always to be updated. We promise not to spam!