Disable postback on image button click asp

Total Post:159

Points:1117
C# 
 1457  View(s)
Ratings:
Rate this:

I have an image button on my asp project that browse an image and display. I am using a script for my project. 

This is my code: 

ASPX: 

<asp:Panel ID="stage" runat="server" cssClass="containment-wrapper" style="border:1px solid #000000;">
         <asp:ImageButton ID="imgBrowse" runat="server" Height="375px" Width="640px" src="#" />
         <input type='file' id="inpUploader" style="visibility: hidden;"/>
</asp:Panel>

JS source: 

function readURL(input) {
    if (input.files && input.files[0]) {
        var reader = new FileReader();
 
        reader.onload = function (e) {
            $('#imgBrowse').attr('src', e.target.result);
        }
 
        reader.readAsDataURL(input.files[0]);
    }

$("#inpUploader").change(function () {
    readURL(this);
});

CS: 

protected void Page_Load(object sender, EventArgs e)
    {
        imgBrowse.Attributes.Add("onclick", "document.getElementById('inpUploader').click();");
    }

My code is working and the image is showing after I select the image but after a few seconds the image lost because the page reloads.

  1. Post:70

    Points:494
    Re: Disable postback on image button click asp

    <asp:Button runat="server"Text="Button" UseSubmitBehavior="false"
    OnClientClick="alert('my client script here');my" /> 
    <script type="text/javascript"> 
    function my__doPostBack(eventTarget, eventArgument) {
        //Just swallow the click without postback of the form
    }
    </script>

      Modified On Apr-07-2018 05:24:30 AM
  1. Post:42

    Points:296
    Re: Disable postback on image button click asp

    just add return false;. 

     protected void Page_Load(object sender, EventArgs e)
        {
            imgBrowse.Attributes.Add("onclick", "document.getElementById('inpUploader').click(); return false;");
        }

      Modified On Apr-07-2018 05:24:49 AM

Answer

NEWSLETTER

Enter your email address here always to be updated. We promise not to spam!