Home > DeveloperSection > Forums > Deploying issue : IIS Error code 0x80070021
Glen Martin
Glen Martin

Total Post:27

Points:191
Posted on    October-23-2015 5:18 AM

 IIS 7 .NET  IIS 
Ratings:


 1 Reply(s)
 739  View(s)
Rate this:
got problem while deploying website. The web application works perfectly while running from visual studio but while i trying to deploy it using IIS, it didn't work. IIS tells that there is problem in web.config.

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.
Module IIS Web Core
Notification BeginRequest
Handler Not yet determined
Error Code 0x80070021
Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \\?\D:\WebProd\WebProd\web.config

Web config syntax:
<?xml version="1.0" encoding="UTF-8"?><!--
  For more information on how to configure your ASP.NET application, please visit
  http://go.microsoft.com/fwlink/?LinkId=169433
  --><configuration>
<appSettings>
     <add key="CrystalImageCleaner-AutoStart" value="true" />
     <add key="CrystalImageCleaner-Sleep" value="60000" />
     <add key="CrystalImageCleaner-Age" value="120000" />
 </appSettings>
    <location path="127.0.0.1" allowOverride="true">
      <system.webServer>
        <security>
          <authentication>
            <!-- note: this is different than previous example, in that  -->
            <!-- the content of the section is in the original place and -->
            <!-- was not moved here; in addition, the section is also    -->
            <!-- specified here, just by its name, so that it gets       -->
            <!-- unlocked only for the site specified in the location.   -->
            <windowsAuthentication/>
          </authentication>
        </security>
      </system.webServer>
    </location>
 <connectionStrings>
<add name="MyDbConn" connectionString="Server=cn-server\cndev2008; Database=WebApp; Integrated Security=SSPI" providerName="System.Data.SqlClient" />
<!--<add name="MyDbConn" connectionString="Server=yoyonk-pc\yonksql; Database=WebApp; Integrated Security=SSPI" providerName="System.Data.SqlClient"/>-->
 </connectionStrings>
<system.web>
<compilation debug="true" targetFramework="4.0">
<assemblies>
<add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"  />
<add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
<add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
<add assembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="log4net, Version=1.2.10.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="CrystalDecisions.ReportSource, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="CrystalDecisions.ReportAppServer.Controllers, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="CrystalDecisions.ReportAppServer.DataDefModel, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
<add assembly="CrystalDecisions.CrystalReports.Engine, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692FBEA5521E1304" />
        <add assembly="CrystalDecisions.ReportAppServer.ClientDoc, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/></assemblies></compilation>
<httpHandlers><add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" /></httpHandlers></system.web>
 
    <system.webServer><handlers>
        <add name="CrystalImageHandler.aspx_GET"  verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" preCondition="integratedMode" />
 </handlers><validation validateIntegratedModeConfiguration="false" />
      
      <defaultDocument enabled="true">
            <files>
                <remove value="index.html" />
                <remove value="iisstart.htm" />
                <remove value="index.htm" />
                <remove value="Default.asp" />
                <remove value="Default.htm" />
                <add value="index.aspx" />
            </files>
        </defaultDocument></system.webServer></configuration>
Please help !!


ezra heywood
ezra heywood

Total Post:145

Points:1019
Supported
Posted on    October-23-2015 7:36 AM

Have you ever tried:
http://support.microsoft.com/kb/942055

Verify framework 2.0 is registered with IIS, If it is not registered, to do this
open the command promt=> C:\Windows\Microsoft.NET\Framework64\v2.0.50727 aspnet_regiis -i

Don't want to miss updates? Please click the below button!

Follow MindStick